Fast Reroute (FRR)






Fast Reroute (FRR)

Cisco IOS and Cisco IOS XR provide FRR for link and node protection. Both operating systems use the facility technique because of its superior scalability. You can use FRR with regular TE LSPs or DS-TE LSPs. In addition, you can configure your network to provide connectivity protection or bandwidth protection to make sure that backup tunnels have sufficient capacity before the point of local repair (PLR) selects them to protect a primary TE LSP. To deploy FRR, you must configure the headend of the primary tunnel to request protection-and you must configure at least one midpoint with a backup tunnel to reroute the primary TE LSPs. The backup tunnel must be a next hop (NHOP) or next-next hop(NNHOP) tunnel that bypasses the failure and intersects the primary TE LSP.

You need to configure which TE LSPs require protection with FRR. Cisco IOS uses the tunnel mpls traffic-eng fast-reroute command that you need to apply on the MPLS TE tunnel interface at the headend. The node-protect and bw-protect keywords are optional and set the corresponding node protection desired and bandwidth protection desired flags in the signaling of the primary TE LSP. Cisco PLRs attempt to provide the best protection possible to a primary TE LSP even if you do not set these flags. Cisco IOS XR uses the fastreroute command on the MPLS TE tunnel to signal that the TE LSP desires protection. Examples 4-44 and 4-45 show MPLS TE tunnels in Cisco IOS and Cisco IOS XR that request FRR protection.

Tunnel Requesting FRR with Node and Bandwidth Protection in Cisco IOS

interface Tunnel1
 description FROM-ROUTER-TO-DST1-FRR-NODEP-BWP
 ip unnumbered Loopback0
 tunnel destination 172.16.255.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth 20000
 tunnel mpls traffic-eng path-option 10 explicit name PATH2
 tunnel mpls traffic-eng fast-reroute bw-protect node-protect
!

Tunnel Requesting FRR Protection in Cisco IOS XR

interface tunnel-te1
 description FROM-ROUTER-TO-DST1-FRR
 ipv4 unnumbered Loopback0
 priority 3 3
 signalled-bandwidth 30000 class-type 1
 destination 172.16.255.2
 fast-reroute
 path-option 10 explicit name PATH1
!

Link and Node Protection

You need to pre-establish a backup TE LSP to implement link and node protection. You can configure this backup with an MPLS TE tunnel interface using the same commands that you use to configure the primary tunnel. The headend of the backup tunnel will always reside on the PLR. Conversely, the tailend will always be the merge point (MP). The backup tunnel can rely on a dynamically computed path or an explicit path. The only obvious restriction is that the path options for the backup tunnel must not use the facility (link, node, or shared-risk link group [SRLG]) whose failure you are trying to protect against. Backup tunnels commonly do not use an explicit bandwidth reservation. Remember that backup tunnels remain unused most of the time, and an explicit reservation limits your ability to share bandwidth.

The tunnel destination determines the type of protection a backup tunnel provides. An NHOP (adjacent neighbor) destination defines a backup tunnel that can protect against the failure of the link that connects to that neighbor. An NNHOP (a neighbor's neighbor) destination protects against the adjacent neighbor failure for those TE LSPs also traversing that second neighbor. Depending on your topology, you may need multiple backup tunnels to fully protect against the failure of an adjacent neighbor. A PLR may also have multiple backup tunnels to the same destination and protect against the same failure. This allows you to provide redundancy in case a backup tunnel fails and to distribute the primary TE LSPs across several backup tunnels.

You need to associate the backup tunnel with a physical interface that will detect the failure. Cisco IOS uses the mpls traffic-eng backup-path interface command for that purpose. Cisco IOS XR uses the backup-path command under a particular interface in the mpls traffic-eng configuration mode. You use the same command regardless of the type of protection you are trying to implement. To accelerate the detection of some node failures, you might need to enable RSVP hello messages or Bidirectional Forwarding Detection (BFD) between the PLR and the adjacent neighbor. In many cases, the PLR will detect the node failure as a link failure.

Examples 4-39 and 4-40 illustrate the configuration of backup tunnels in Cisco IOS and Cisco IOS XR, respectively. In both examples, one of the tunnels provides link protection; the other tunnel provides node protection. All tunnels use dynamic path computation that excludes the appropriate node or link. Figure shows the details of the network topology and the tunnel paths.

Sample Network Topology with Link and Node Protection


In Figure, node A has an NHOP tunnel, Tunnel1, and NNHOP tunnel, Tunnel2. Tunnel1 provides link protection, with interface POS0/1/1 acting as the failure-detection point. Tunnel2 provides node protection, with interface POS1/0/0 as failure-detection point. Similarly, Figure shows an NHOP tunnel, tunnel-te1, and an NNHOP tunnel, tunnel-te2, on node B. In this example, tunnel-te1 provides link protection and uses interface POS0/3/0/1 as the failure-detection point. Similarly, tunnel-te2 provides node protection and uses interface POS0/3/0/2 for the same purpose.

Backup Tunnels for Link and Node Protection in Cisco IOS

interface Tunnel1
 description NHOP-BACKUP
 ip unnumbered Loopback0
 tunnel destination 172.16.255.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng path-option 10 explicit name PATH1
!
interface Tunnel2
 description NNHOP-BACKUP
 ip unnumbered Loopback0
 tunnel destination 172.16.255.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng path-option 10 explicit name PATH2
!
interface POS0/1/1
 ip address 172.16.4.3 255.255.255.254
 mpls traffic-eng tunnels
 mpls traffic-eng backup-path Tunnel1
 ip rsvp bandwidth 155000
!
interface POS1/0/0
 ip address 172.16.192.5 255.255.255.254
 mpls traffic-eng tunnels
 mpls traffic-eng backup-path Tunnel2 
 ip rsvp bandwidth 155000
!
ip explicit-path name PATH1 enable
 exclude-address 172.16.4.2
!
ip explicit-path name PATH2 enable
 exclude-address 172.16.255.130
!

Backup Tunnels for Link and Node Protection in Cisco IOS XR

explicit-path name PATH1
 index 1 exclude-address ipv4 unicast 172.16.192.1
!
explicit-path name PATH2
 index 1 exclude-address ipv4 unicast 172.16.255.131
!
interface tunnel-te1
 description NHOP-BACKUP
 ipv4 unnumbered Loopback0
 destination 172.16.255.130
 path-option 10 explicit name PATH1
!
interface tunnel-te2
 description NNHOP-BACKUP
 ipv4 unnumbered Loopback0
 destination 172.16.255.130
 path-option 10 explicit name PATH2
!
mpls traffic-eng
 interface POS0/3/0/1
  backup-path tunnel-te 1
 !
 interface POS0/3/0/2
  backup-path tunnel-te 2
 ! 
! 

Note

Cisco IOS provides the automatic creation of backup TE LSPs. You enable this behavior with the mpls traffic-eng auto-tunnel backup command. A detailed discussion of this functionality is beyond the scope of this book. Consult the Cisco IOS documentation for further details.


Bandwidth Protection

The PLR can manage the capacity of backup tunnels to provide bandwidth protection. You can use the tunnel mpls traffic-eng backup-bw command and the backup-bw command to explicitly configure the backup tunnel capacity in Cisco IOS and Cisco IOS XR, respectively. They provide local knowledge of the capacity of the backup tunnels and do not instruct the PLR to signal a bandwidth reservation. With proper design, a PLR can provide bandwidth protection even if the backup tunnel does not reserve bandwidth. A PLR provides bandwidth protection for any primary TE LSP that requests protection if possible. However, it gives precedence to TE LSPs with nonzero bandwidth that request bandwidth protection.

You configure the capacity of a backup tunnel in terms of a bandwidth amount and the Class-Types they can protect. With respect to the bandwidth amount, you can configure the backup with an explicit (limited) bandwidth amount or as a backup with unlimited bandwidth. With respect to Class-Types, you can configure a backup tunnel to protect TE LSPs using the global pool (CT0), the subpool (CT1), or any bandwidth pool (CT0 or CT1). Bandwidth protection enables you to define multiple backup tunnels with different capacity configuration to protect against the same failure. When the PLR detects a TE LSP that requires protection, it evaluates which backup tunnel can provide the best level of bandwidth protection.

Figure shows the criteria that the PLR uses to select from among multiple backup tunnels to protect a primary TE LSP. In general, the PLR prefers NNHOP over NHOP tunnels because they can protect against both a node and a link failure. It prefers backup tunnels with an explicit (limited) bandwidth amount. Finally, it prefers an exact Class-Type match over backup tunnels that protect any Class-Type. The most preferable backup tunnel will be an NNHOP tunnel with a limited bandwidth amount and an exact class match. In contrast, the least desirable backup tunnel will be an NHOP tunnel with unlimited bandwidth for any Class-Type. This tunnel provides the lowest certain of bandwidth guarantee.

Priorities for Backup Tunnel Selection in Cisco IOS and Cisco IOS XR

Preference

Backup Tunnel Destination

Bandwidth Amount

Bandwidth Pool

0 (best)

NNHOP

Limited

Exact match

1

NNHOP

Limited

Any

2

NNHOP

Unlimited

Exact match

3

NNHOP

Unlimited

Any

4

NHOP

Limited

Exact match

5

NHOP

Limited

Any

6

NHOP

Unlimited

Exact match

7 (worst)

NHOP

Unlimited

Any


Figure shows the bandwidth protection configuration on a PLR in Cisco IOS and Cisco IOS XR, respectively. Examine Figure.

Backup Tunnels for Bandwidth Protection in Cisco IOS

interface Tunnel1
 description NNHOP-BACKUP-40M-CT1
 ip unnumbered Loopback0
 tunnel destination 172.16.255.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng backup-bw 40000 class-type 1
 tunnel mpls traffic-eng path-option 10 explicit name PATH1
! 
interface Tunnel2
 description NNHOP-BACKUP-90M-CT0
 ip unnumbered Loopback0
 tunnel destination 172.16.255.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng backup-bw 90000 class-type 0 
 tunnel mpls traffic-eng path-option 10 explicit name PATH2
!
interface Tunnel3
 description NHOP-BACKUP-90M-ANY-CT
 ip unnumbered Loopback0
 tunnel destination 172.16.255.130
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng backup-bw 90000
 tunnel mpls traffic-eng path-option 10 explicit name PATH3
!
interface POS1/0/0
 ip address 172.16.192.5 255.255.255.254
 mpls traffic-eng tunnels
 mpls traffic-eng backup-path Tunnel1
 mpls traffic-eng backup-path Tunnel2
 mpls traffic-eng backup-path Tunnel3
 ip rsvp bandwidth rdm 155000 sub-pool 55000
!
ip explicit-path name PATH1 enable
 exclude-address 172.16.255.130
!
ip explicit-path name PATH3 enable
 next-address 172.16.192.2
 next-address 172.16.192.1
!
ip explicit-path name PATH2 enable
 next-address 172.16.4.2
! 

Sample Network Topology with Cisco IOS PLR Providing Bandwidth Protection


In Figure, interface POS1/0/0 can trigger three backup tunnels:

  • Tunnel1 is an NNHOP backup tunnel protecting 40,000 kbps for CT TE LSPs.

  • Tunnel2 is an NNHOP tunnel that can protect 90,000 kbps for CT0 LSPs.

Tunnel3 is an NHOP tunnel that can protect 90,000 kbps for TE LSPs of any CT.

Examine Figure.

Figure shows three backup tunnels that could re-reroute traffic in case of a failure on interface POS0/3/0/1:

  • tunnel-te1 is an NHOP tunnel protecting 55,000 kbps for CT0 TE LSPs.

  • tunnel-te2 is an NNHOP tunnel that supports a protection capacity of 20,000 for CT0 TE LSPs.

tunnel-te3 is an NHOP tunnel that protects 25,000 kbps for CT1 TE LSPs.

Sample Network Topology with Cisco IOS XR PLR Providing Bandwidth Protection


Bandwidth Protection in Cisco IOS XR

interface tunnel-te1
 description NHOP-BACKUP-55M-CTO
 ipv4 unnumbered Loopback0
 backup-bw 55000 class-type 0
 destination 172.16.255.130
 path-option 10 explicit name PATH1
!
interface tunnel-te2
 description NNHOP-BACKUP-20M-CTO
 ipv4 unnumbered Loopback0
 backup-bw 20000 class-type 0
 destination 172.16.255.2
 path-option 10 explicit name PATH2
!
interface tunnel-te3
 description NHOP-BACKUP-25M-ANY-CT
 ipv4 unnumbered Loopback0
 backup-bw 25000 class-type 1
 destination 172.16.255.130
 path-option 10 explicit name PATH1
!
mpls traffic-eng
 interface POS0/3/0/1
  backup-path tunnel-te 1
  backup-path tunnel-te 2
  backup-path tunnel-te 3
 !
!

Verifying FRR on the Headend

In Cisco IOS, you can verify the operation of FRR on a headend by examining the Path and Resv state of the primary TE LSP. The show ip rsvp sender detail command provides the most detail about the Path state of a TE LSP. This command enables you to verify whether the node is signaling the TE LSP with any of the FRR flags (local protection desired, node protection desired, or bandwidth protection desired). Similarly, the show ip rsvp reservation detail command provides the details of the Resv state. This command displays the hop-by-hop route information that the signaling packets collected. In Figure, you see that the first node in the path is providing bandwidth protection for an LSP with an NNHOP backup tunnel.

Examining Primary TE LSP Protection at the Headend in Cisco IOS

Router#show ip rsvp reservation detail
Reservation: 
  Tun Dest:   172.16.255.2 Tun ID: 1 Ext Tun ID: 172.16.255.1
  Tun Sender: 172.16.255.1 LSP ID: 6
  Next Hop: 172.16.0.3 on POS1/0/0
  Label: 30 (outgoing) 
  Reservation Style is Shared-Explicit, QoS Service is Controlled-Load
  Resv ID handle: 06000410. 
  Created: 16:25:39 UTC Tue Jul 29 2003
  Average Bitrate is 20M bits/sec, Maximum Burst is 1K bytes
  Min Policed Unit: 0 bytes, Max Pkt Size: 0 bytes
  RRO: 
    172.16.255.131/32, Flags:0x2D (Local Prot Avail/Has BW/to NNHOP, Node-id)
      Label subobject: Flags 0x1, C-Type 1, Label 30
    172.16.255.130/32, Flags:0x20 (No Local Protection, Node-id) 
      Label subobject: Flags 0x1, C-Type 1, Label 33
    172.16.255.2/32, Flags:0x20 (No Local Protection, Node-id) 
      Label subobject: Flags 0x1, C-Type 1, Label 0
  Status:
  Policy: Accepted. Policy source(s): MPLS/TE
Router# 

Figure shows how to verify the operation of FRR on a headend in Cisco IOS XR. In this case, the show mpls traffic-eng tunnels command provides enough detail about the RSVP state of the TE LSP. In particular, the decoded route record object (RRO) will show you, for every hop in the path, whether the TE LSP has local protection, whether protection is active (the node is rerouting the TE LSP through a backup), and whether bandwidth or node protection is available. The flags in the IPv4/IPv6 subobject contain that information. In this example, the first hop (node ID 172.16.255.131) provides local protection with node and bandwidth protection (flags 0x2d).

Examining Primary TE LSP Protection at the Headend in Cisco IOS XR

RP/0/4/CPU0:Router#show mpls traffic-eng tunnels role head detail
Signalling Summary:
              LSP Tunnels Process:  running 
                     RSVP Process:  running 
                       Forwarding:  enabled
          Periodic reoptimization:  every 3600 seconds, next in 1244 seconds
           Periodic FRR Promotion:  every 300 seconds, next in 173 seconds
      Periodic auto-bw collection:  disabled
Name: tunnel-te1  Destination: 172.16.255.2 
  Status:
    Admin:    up Oper:   up   Path:  valid   Signalling: connected
    path option 10, type explicit PATH1 (Basis for Setup, path weight 3)
    G-PID: 0x0800 (derived from egress interface properties)
Config Parameters: 
  Bandwidth: 30000 kbps (CT1) Priority: 3 3 Affinity: 0x0/0xffff
  Metric Type: TE (default) 
  AutoRoute: disabled LockDown: disabled Loadshare: 30000 bw-based
  Auto-bw: disabled(0/0) 0 Bandwidth Requested: 30000
  Direction: unidirectional
  Endpoint switching capability: unknown, encoding type: unassigned
  Transit switching capability: unknown, encoding type: unassigned
History: 
  Tunnel has been up for: 02:01:00
  Current LSP: 
    Uptime: 02:01:00
Current LSP Info: 
  Instance: 9, Signaling Area: ospf DEFAULT area 0
  Uptime: 02:01:00
  Incoming Label: explicit-null
  Outgoing Interface: POS0/3/0/2, Outgoing Label: 33
  Path Info: 
    Explicit Route: 
      Strict, 172.16.192.3
      Strict, 172.16.192.4
      Strict, 172.16.4.0
      Strict, 172.16.255.2
    Record Route: None
    Tspec: avg rate=30000 kbits, burst=1000 bytes, peak rate=30000 kbits
  Resv Info: 
    Record Route: 
      IPv4 172.16.255.131, flags 0x2d
      Label 33, flags 0x1
      IPv4 172.16.255.130, flags 0x20
      Label 32, flags 0x1
      IPv4 172.16.255.2, flags 0x20
      Label 0, flags 0x1
    Fspec: avg rate=30000 kbits, burst=1000 bytes, peak rate=30000 kbits
Displayed 1 (of 1) heads, 0 (of 1) midpoints, 0 (of 0) tails
Displayed 1 up, 0 down, 0 recovering, 0 recovered heads
RP/0/4/CPU0:Router# 

Examine the information in Figure.

Flags in the RRO IPv4/IPv6 Subobject

Value (Hexadecimal)

Flag

Description

0x01

Local protection available

Node can protect TE LSP.

0x02

Local protection in use

Node is rerouting the TE LSP through the backup tunnel.

0x04

Bandwidth protection

Node can provide bandwidth protection for the TE LSP.

0x08

Node protection

Node can provide protection against downstream node failure.

0x10

Preemption pending

TE LSP preemption pending. Headend should reroute the TE LSP.

0x20

Node ID

Address represents node ID rather than a link address.


Verifying FRR on the PLR

A PLR will provide the details of the primary TE LSPs it is protecting and what backup tunnel it uses for that purpose.

Figure shows the output of the show mpls traffic-eng fast-reroute databasecommand in Cisco IOS. If the PLR has selected a backup for a primary TE LSP, the command displays the TE LSP, the input label, the output interface, the output label, the output backup tunnel, and the backup label. The protection status can be ready when a failure has not occurred or active when the node is rerouting the primary TE LSP through the backup.

Examining the FRR Database on the PLR in Cisco IOS

Router#show mpls traffic-eng fast-reroute database
Headend frr information:
Protected tunnel              In-label Out intf/label  FRR intf/label Status
LSP midpoint frr information:
LSP identifier                In-label Out intf/label  FRR intf/label Status
172.16.255.1 1 [6]            30       PO1/0/0:33     Tu2:implicit-nul ready
172.16.255.129 1 [9]          33       PO1/0/0:32     Tu1:implicit-nul ready
Router#
*Nov 10 16:32:52.852: %LINK-3-UPDOWN: Interface POS1/0/0, changed state to down
*Nov 10 16:32:52.856: %OSPF-5-ADJCHG: Process 100, Nbr 172.16.255.130 on POS1/0/0
from FULL to DOWN, Neighbor Down: Interface down or detached
*Nov 10 16:32:53.852: %LINEPROTO-5-UPDOWN: Line protocol on Interface POS1/0/0,
changed state to down
Router#
Router#show mpls traffic-eng fast-reroute database
Headend frr information: 
Protected tunnel	      In-label Out intf/label  FRR intf/label Status
LSP midpoint frr information:
LSP identifier                In-label Out intf/label  FRR intf/label Status
172.16.255.1 1 [6]            30 PO1/0/0:33           Tu2:implicit-nul active
172.16.255.129 1 [9]          33 PO1/0/0:32           Tu1:implicit-nul active
Router# 

Cisco IOS XR supports the same command with equivalent information. Figure shows the command output in Cisco IOS XR. Both examples show the command output before and while the node reroutes the TE LSPs.

Examining the FRR Database on the PLR in Cisco IOS XR


RP/0/4/CPU0:Router#show mpls traffic-eng fast-reroute database
LSP midpoint FRR information:
LSP Identifier                Local Out Intf/         FRR Intf/ Status 
                              Label Label             Label
----------------------------  ----- ----------------  ---------------- -------
172.16.255.1 1 [677]          83    PO0/3/0/1:31 tt2:ExpNull4 Ready
RP/0/4/CPU0:Router#
RP/0/4/CPU0:Router#LC/0/3/CPU0:May 2 01:23:29.614 : ifmgr[154]: %PKT_INFRA-LINK-3-
UPDOWN : Interface POS0/3/0/1, changed state to Down
LC/0/3/CPU0:May 2 01:23:29.615 : ifmgr[154]: %PKT_INFRA-LINEPROTO-5-UPDOWN : Line
protocol on Interface POS0/3/0/1, changed state to Down
RP/0/4/CPU0:May 2 01:23:29.643 : ospf[269]: %ROUTING-OSPF-5-ADJCHG : Process
DEFAULT, Nbr 172.16.255.130 on POS0/3/0/1 from FULL to DOWN, Neighbor Down:
interface down or detached
RP/0/4/CPU0:Router#
RP/0/4/CPU0:Router#show mpls traffic-eng fast-reroute database
LSP midpoint FRR information:
LSP Identifier                Local  Out Intf/        FRR Intf/       Status
                              Label  Label            Label
----------------------------- ------ ---------------- --------------- -------
172.16.255.1 1 [677]          83     tt2:ExpNull4    Active                               
                               
RP/0/4/CPU0:Router# 

You can use the show mpls traffic-eng tunnels protection command to examine the details of a protected TE LSP on a PLR. You can use the command in Cisco IOS and Cisco IOS XR. Figure shows a protected TE LSP traversing interface POS1/0/0. The backup selection process has chosen Tunnel2 to protect this TE LSP. See Figure for the backup tunnel configuration. Figure shows the equivalent command output in Cisco IOS XR. In that example, the PLR has selected tunnel-te2 to reroute the protected TE LSP. See Figure for the backup tunnel configuration

Examining Protected TE LSPs on the PLR in Cisco IOS

Router#show mpls traffic-eng tunnels protection
NNHOP-BACKUP-40M-CT1
 LSP Head, Tunnel1, Admin: up, Oper: up
 Src 172.16.255.131, Dest 172.16.255.2, Instance 4
 Fast Reroute Protection: None
 Path Protection: None
NNHOP-BACKUP-90M-CT0 
 LSP Head, Tunnel2, Admin: up, Oper: up
 Src 172.16.255.131, Dest 172.16.255.2, Instance 1
 Fast Reroute Protection: None
 Path Protection: None
NHOP-BACKUP-90M-ANY-CT 
 LSP Head, Tunnel3, Admin: up, Oper: up
 Src 172.16.255.131, Dest 172.16.255.130, Instance 1
 Fast Reroute Protection: None
 Path Protection: None
LSP Tunnel FROM-ROUTER-TO-DST1-FRR-NODEP-BWP is signalled, connection is up 
  InLabel : POS2/0/0, 30
  OutLabel : POS1/0/0, 33
  FRR OutLabel : Tunnel2, explicit-null
  RSVP Signalling Info: 
       Src 172.16.255.1, Dst 172.16.255.2, Tun_Id 1, Tun_Instance 6
    RSVP Path Info: 
      My Address: 172.16.192.5
      Explicit Route: 172.16.192.4 172.16.4.0 172.16.255.2
      Record Route: NONE
      Tspec: ave rate=20000 kbits, burst=1000 bytes, peak rate=20000 kbits
    RSVP Resv Info: 
      Record Route: 172.16.255.130(33) 172.16.255.2(0)
      Fspec: ave rate=20000 kbits, burst=1000 bytes, peak rate=20000 kbits
LSP Tunnel FROM-ROUTER-TO-DST1-FRR is signalled, connection is up 
  InLabel : POS0/0/0, 33
  OutLabel : POS1/0/0, 32
  FRR OutLabel : Tunnel1, explicit-null
  RSVP Signalling Info: 
       Src 172.16.255.129, Dst 172.16.255.2, Tun_Id 1, Tun_Instance 9
    RSVP Path Info: 
      My Address: 172.16.192.5
      Explicit Route: 172.16.192.4 172.16.4.0 172.16.255.2
      Record Route: NONE
      Tspec: ave rate=30000 kbits, burst=1000 bytes, peak rate=30000 kbits
    RSVP Resv Info: 
      Record Route: 172.16.255.130(32) 172.16.255.2(0)
      Fspec: ave rate=30000 kbits, burst=1000 bytes, peak rate=30000 kbits
Router# 

Examining Protected TE LSPs on the PLR in Cisco IOS XR

RP/0/4/CPU0:Router#show mpls traffic-eng tunnels protection
NHOP-BACKUP-90M-ANY-CT 
  LSP Midpoint, signaled, connection up
  Src: 172.16.255.131, Dest: 172.16.255.130, Instance: 1
  Fast Reroute Protection: None
NHOP-BACKUP-55M-CT0 
  LSP Head, Admin: up, Oper: up
  Src: 172.16.255.129, Dest: 172.16.255.130, Instance: 1
  Fast Reroute Protection: None
NNHOP-BACKUP-20M-CT0 
  LSP Head, Admin: up, Oper: up
  Src: 172.16.255.129, Dest: 172.16.255.2, Instance: 1
  Fast Reroute Protection: None
NHOP-BACKUP-25M-ANY-CT 
  LSP Head, Admin: up, Oper: up
  Src: 172.16.255.129, Dest: 172.16.255.130, Instance: 1
  Fast Reroute Protection: None
FROM-ROUTER-TO-DST1-FRR-NODEP-BWP 
  LSP Midpoint, signaled, connection up
  Src: 172.16.255.1, Dest: 172.16.255.2, Instance: 677
  Fast Reroute Protection: Requested 
    Inbound: FRR Inactive 
     LSP signalling info: 
      Original: in i/f: POS0_3_0_0, label: 83, phop: 172.16.0.0
    Outbound: FRR Ready 
     Backup tunnel-te2 to LSP nnhop
      tunnel-te2: out i/f: POS0/3/0/2
     LSP signalling info: 
      Original: out i/f: POS0/3/0/1, label: 31, nhop: 172.16.192.1
      With FRR: out i/f: tunnel-te2, label: 0
     LSP bw: 20000 kbps, Backup level: CT0 limited, type: CT0
RP/0/4/CPU0:Router# 

The show mpls traffic-eng tunnels backup command enables you to obtain details about the backup tunnels on the PLR. The output shows you how many TE LSPs the backup tunnel is protecting. It also shows you the current allocation of backup bandwidth. Figure illustrates the command output in Cisco IOS. In this case, Tunnel2 is protecting one TE LSP and has allocated 10,000 kbps of the total 90,000 kbps of backup bandwidth. Figure shows the equivalent command output in Cisco IOS XR. In that example, te-tunnel2 is protecting one TE LSP and has allocated all its backup bandwidth (20,000 kbps).

Examining Backup Tunnels on the PLR in Cisco IOS

Router#show mpls traffic-eng tunnels backup
NNHOP-BACKUP-40M-CT1 
  LSP Head, Tunnel1, Admin: up, Oper: up
  Src 172.16.255.131, Dest 172.16.255.2, Instance 4
  Fast Reroute Backup Provided:
    Protected i/fs: PO1/0/0
    Protected lsps: 1
    Backup BW: sub-pool; limit: 40000 kbps, inuse: 30000 kbps (BWP inuse: 0 kbps)      
NNHOP-BACKUP-90M-CT0 
  LSP Head, Tunnel2, Admin: up, Oper: up
  Src 172.16.255.131, Dest 172.16.255.2, Instance 1
  Fast Reroute Backup Provided: 
    Protected i/fs: PO1/0/0
    Protected lsps: 1
    Backup BW: global pool; limit 90000 kbps, inuse: 20000 kbps (BWP inuse: 20000
    kbps) 
NHOP-BACKUP-90M-ANY-CT
  LSP Head, Tunnel3, Admin: up, Oper: up
  Src 172.16.255.131, Dest 172.16.255.130, Instance 1
  Fast Reroute Backup Provided: 
    Protected i/fs: PO1/0/0
    Protected lsps: 0
    Backup BW: any pool; limit: 90000 kbps, inuse: 0 kbps (BWP inuse: 0 kbps)
Router#

Examining Backup Tunnels on the PLR in Cisco IOS XR

RP/0/4/CPU0:Router#show mpls traffic-eng tunnels backup
tunnel-te1 
 Admin: up, Oper: up
 Src: 172.16.255.129, Dest: 172.16.255.130, Instance: 1
 Fast Reroute Backup Provided: 
  Protected LSPs: 0
  Backup BW: CT0; limit: 55000 kbps, Inuse: 0 kbps
  Protected i/fs: POS0/3/0/1
tunnel-te2 
 Admin: up, Oper: up
 Src: 172.16.255.129, Dest: 172.16.255.2, Instance: 1
 Fast Reroute Backup Provided: 
  Protected LSPs: 1
  Backup BW: CT0; limit: 20000 kbps, Inuse: 20000 kbps
  Protected i/fs: POS0/3/0/1
tunnel-te3
 Admin: up, Oper: up
 Src: 172.16.255.129, Dest: 172.16.255.130, Instance: 1
 Fast Reroute Backup Provided: 
  Protected LSPs: 0
  Backup BW: any-class; limit: 25000 kbps, Inuse: 0 kbps
  Protected i/fs: POS0/3/0/1
RP/0/4/CPU0:Router# 



 Python   SQL   Java   php   Perl 
 game development   web development   internet   *nix   graphics   hardware 
 telecommunications   C++ 
 Flash   Active Directory   Windows